How can we help?

System requirements and browsers


Flare is cloud accounting software that runs in your browser. To get the best experience with Flare, we recommend that you use the latest version of Microsoft Edge, Internet Explorer, Chrome, Firefox or Safari.

Web browsers

Download or upgrade to the latest version of:

Activate/enable JavaScript

Flare requires JavaScript. JavaScript is enabled by default in most modern browsers. If you have trouble logging into Flare, check whether JavaScript is disabled.

Enable JavaScript in Internet Explorer, Chrome, Firefox, Safari.
When you go to the page above, you’ll see a message: "JavaScript is enabled in your web browser" if JavaScript is turned on.

You may also visit the online support pages of each browser vendor:

Configure pop-up blockers to allow Flare to open new windows

Certain actions you take in Flare may open a new window, such as when printing invoices or bills. When prompted by your browser's pop-up blocker, allow Flare to open a new window.

Pop-up blocker notification

Learn how to allow pop-ups from the Flare domain in:

Mobile device support

Flare was created with a responsive design and can be viewed in most modern browsers on desktop or tablet. While many of Flare's features will also scale to fit smartphone screen widths, certain data tables will cause side scrolling on small screens. A more smartphone-friendly version of Flare will be available in a future release.

Have more questions? Submit a request